Cobra 29 ltd receive problem

For discussions on CB Radio Repair and Troubleshooting, do not post modification requests here, use the Modifications forum !
User avatar
marveylus22
Light User
Light User
Posts: 109
Joined: Saturday 19th May 2007, 11:03
Location: Las Vegas Nevada

Cobra 29 ltd receive problem

Postby marveylus22 » Saturday 14th Jun 2008, 18:02

How to explain this one... Okay here we go. When the radios on the receive is cracking at low volume, but when you turn the volume up it clears up. So I replaced the on/off squelch pot with a new one. It does the same thing. I notice the mic socket is a little worn, and I will also change that out. Any other ideas? Thank you.
When the Boogeyman goes to sleep every night he checks his closet for Chuck Norris.

ramblingman
Technical Helper
Technical Helper
Posts: 331
Joined: Sunday 21st Jan 2007, 16:35
Location: mississippi

Postby ramblingman » Saturday 14th Jun 2008, 19:06

Probably all you need to do is get some contact
cleaner and clean the volume control.

User avatar
The Defpom
Site Admin
Site Admin
Posts: 435
Joined: Friday 20th Aug 2004, 18:06
Location: New Zealand
Contact:

Postby The Defpom » Saturday 14th Jun 2008, 19:39

Check the external speaker socket, they sometimes open up, it may be corroded as well, and the higher voltage from turning up the volume may just allow it to work, if in doubt replace it.

The next test is to plug in an external speaker and see if it sounds the same, if it is OK, then replace the internal speaker.

User avatar
marveylus22
Light User
Light User
Posts: 109
Joined: Saturday 19th May 2007, 11:03
Location: Las Vegas Nevada

Postby marveylus22 » Tuesday 17th Jun 2008, 15:14

Got it. Thank you sir.
When the Boogeyman goes to sleep every night he checks his closet for Chuck Norris.

corbingravely
Newbie
Newbie
Posts: 3
Joined: Thursday 5th Dec 2013, 23:18
First Name: Corbin
Location: India

Re: Cobra 29 ltd receive problem

Postby corbingravely » Friday 20th Oct 2017, 5:35

Hey marvey,

Is the sound wavering. I mean, is it going up and then going down all of a sudden or just flipping out. If yes then, I think it might be a problem with the fuse. There is a small fuse, i don't know the correct name of the fuse, but changing it fixed it for me. The repairman told me that if there is a fluctuation in the sound wave a weak fuse will get fried. So that was my problem. I think that might be yours as well.


Return to “CB Radio Repair and Troubleshooting”



Who is online

Users browsing this forum: No registered users and 17 guests