cobra 29LTD chrome need help with receive

For discussions on CB Radio Repair and Troubleshooting, do not post modification requests here, use the Modifications forum !
Post Reply
dss56
Newbie
Newbie
Posts: 1
Joined: Saturday 14th Jun 2014, 7:10
First Name: Bob
Location: Boston Ma.

cobra 29LTD chrome need help with receive

Post by dss56 » Wednesday 27th Feb 2019, 11:37

Another 29 bites the dust.

Customer brought in a Cobra 29LTD Chrome.
Radio does transmit and receive.
The receive is very noisy lots of static when people are talking.
When channel is silent from talking there are pulses of static in the audio.
Also the rf gain does not fully work
it will work a tad but when turned totally off the radio is still making static noise in receive.
I put a regular 29LTD classic beside it and receive is nice and steady and rf gain will turn receive
almost off to silent.
The radios are basically the same but there is a difference.
That is why I'm looking for a chrome 29LTD schamatic.

Any suggestions on the static riding in on the receive very erratic like a loose antenna connection.
I checked the board for cold solder joints. All look good.
Mic is ok /output ok/audio ok/ radio has builtin Talk back thats ok/

I keyed up a radio about 8 feet away with a dummy load and a mic plug with a toggle on it (test plug)

The cobra 29 chrome needle moves up but the static comes in with the carrier, there should be nothing as there is no mic on the other radio just a dead carrier no modulation.

Same static with a regular receive and a close carrier receive. I replaced D 1/2/3 cap 11 and 12 also tr 6 with all new parts and the same problem.

any suggestions? thanks

Post Reply

Return to “CB Radio Repair and Troubleshooting”