President Lincoln & Uniden 2830 No RX audio fault found

For discussions on CB Radio Repair and Troubleshooting, do not post modification requests here, use the Modifications forum !
Post Reply
xraylima5
Newbie
Newbie
Posts: 1
Joined: Wednesday 25th Feb 2009, 12:11
First Name: John
Location: UK

President Lincoln & Uniden 2830 No RX audio fault found

Post by xraylima5 » Wednesday 4th Mar 2009, 11:05

I have traced the source of a no RX audio fault on my Uniden 2830 and would like to share it with the forum. The radio S meter and RX/TX functioned normally but there was no receive audio in any mode. The fault turned out to be C33 a 47uV electrolytic capacitor in the collector circuit of transistor Q9, the squelch gate/switch. It was short circuit, thus dragging the collector volts on Q9 down to ground. Replace the capacitor with a 16V rated one. The use of these 10V capacitors in 8V DC circuits is a problem in these radios as we know from the famous short circuit C60 fault that they suffer.

My radio had been in the loft for years and was working fine when put away, so it was quite a surprise when it did not work on reconnecting it. I use it for driving 28MHz IF Amateur Radio transverters.

Hope this helps a few people out.
73
John
Last edited by xraylima5 on Saturday 7th Mar 2009, 13:18, edited 2 times in total.


Dar Kuma
Newbie
Newbie
Posts: 2
Joined: Friday 19th Jun 2009, 9:08
First Name: Dar
Location: uk
Contact:

Re: President Lincoln & Uniden 2830 No RX audio fault found

Post by Dar Kuma » Friday 19th Jun 2009, 9:27

I too had this problem with a Uniden 2830, After I got a friend who is also on here ask a few questions I was told to follow certain instructions and replaced a couple of capacitors, (one being C33) I still couldn't get any RX receive.

But I did get the button bleep back again after putting in a new C33 .

Unfortunately I had to send it down to the local rig doctor as I didn't really have time to sort it out myself.

Post Reply

Return to “CB Radio Repair and Troubleshooting”