Page 1 of 1

President Lincoln & Uniden 2830 No RX audio fault found

Posted: Wednesday 4th Mar 2009, 11:05
by xraylima5
I have traced the source of a no RX audio fault on my Uniden 2830 and would like to share it with the forum. The radio S meter and RX/TX functioned normally but there was no receive audio in any mode. The fault turned out to be C33 a 47uV electrolytic capacitor in the collector circuit of transistor Q9, the squelch gate/switch. It was short circuit, thus dragging the collector volts on Q9 down to ground. Replace the capacitor with a 16V rated one. The use of these 10V capacitors in 8V DC circuits is a problem in these radios as we know from the famous short circuit C60 fault that they suffer.

My radio had been in the loft for years and was working fine when put away, so it was quite a surprise when it did not work on reconnecting it. I use it for driving 28MHz IF Amateur Radio transverters.

Hope this helps a few people out.
73
John

Re: President Lincoln & Uniden 2830 No RX audio fault found

Posted: Saturday 7th Mar 2009, 11:30
by The Defpom
Thanks for the info.

Re: President Lincoln & Uniden 2830 No RX audio fault found

Posted: Friday 19th Jun 2009, 9:27
by Dar Kuma
I too had this problem with a Uniden 2830, After I got a friend who is also on here ask a few questions I was told to follow certain instructions and replaced a couple of capacitors, (one being C33) I still couldn't get any RX receive.

But I did get the button bleep back again after putting in a new C33 .

Unfortunately I had to send it down to the local rig doctor as I didn't really have time to sort it out myself.