Cobra 150 gtl dx with NO receive?!?!?!?

For discussions on CB Radio Repair and Troubleshooting, do not post modification requests here, use the Modifications forum !
Post Reply
jstahnke
Dead Key
Dead Key
Posts: 11
Joined: Wednesday 30th Jul 2008, 5:50
Location: NJ, USA

Cobra 150 gtl dx with NO receive?!?!?!?

Post by jstahnke » Tuesday 5th May 2009, 12:14

Radio Make and Model: Cobra 150 gtl dx
PCB Number:
PLL Number:
Test gear available: watt, swr, multimeter, soldering equip, miscellanious parts.
Symptoms: Radio wont receive any signals, only static across every channel (even ch. 19) It would be a whole lot easier if i had a freq counter, but unfortunately i do not. It is acting as if it is stuck receiving a random frequency outside of the regular 40 with no stations talking..no matter what channel and/or band i set it to.

What is working: Everything works fine in TX, like i said even receive is about an S-3 with noise, it just won't pick up any stations (even on channel 19) i even pick up some "splash" so it is definetly receiving something on some frequency

What has been tried: antenna and swr's have been triple checked for shorts.

Did it suddenly happen ?: was bought this way
Anything else that may be of help?: I know what your thinking, but it IS modified to receive the 11m band. I did the work personally and can assure that it is not a botched channel modification. I was extremely careful taking out r138. PLEASE, ANY HELP IS GREATLY APPRECIATED!!!!! THANKS!!!!

Post Reply

Return to “CB Radio Repair and Troubleshooting”