President Lincoln - Driver-(Bias)-Problem

For discussions on CB Radio Repair and Troubleshooting, do not post modification requests here, use the Modifications forum !
Post Reply
Posts: 7
Joined: Saturday 1st Aug 2009, 1:06
First Name: Joerg
Location: Karlsruhe/GER

President Lincoln - Driver-(Bias)-Problem

Post by Joerg » Friday 25th Dec 2009, 14:33

Radio Make and Model: President Lincoln
PCB Number: PB111AE (1999 Uniden)
PLL Number:
Test gear available: Conter, Oszi, DMM, PM...
Symptoms: Driver-Bias running high

What is working: everything else

What has been tried: Bias-Diodes, Bias-Circuit, PCB-Faults

Did it suddenly happen ?: Got it that way, so I dont know
Anything else that may be of help?: the 2166 wont work, a 1969 blew out - the 2078 works fine, but bias >900 mA!


first: the rig runs fine, but It is not possible to adjust the DRIVER-bias probably. I can set the bias of the 477 to 50mA, but not the driver. It starts at 950mA and runs high to far over 1 Amp, counting about 30mA a second. The rig works, it wont run hot, the spectrum is "clean", modulation on all modes OK - but something is wrong. Bias-Diodes both OK (as far as I can test them).

I got a new 2166 (the original) in it - same game - but just 100mW max-out. With the 2078 everything looks normal (12W AM/FM, 23-25W SSB - with room up to 40W). The 2166 is OK, I just swaped them again and testet it with the DMM. 570 forward, dead backward -> OK, but it dont work in *this* Lincoln....

Maybe one of the caps is faulty, I tested them "cold" and they SEEM to be OK. So maybe one have an idea? What I NOT tested yet is the pre-driver-stage. Because with the 2078 everythings working (so far...), I think, this must be all right.

Thanks in advance.

Post Reply

Return to “CB Radio Repair and Troubleshooting”