Page 1 of 1

President Lincoln control buttons not working

Posted: Saturday 5th Mar 2011, 9:00
by absorbentgnome
Radio Make and Model: President Lincoln
PCB Number:
PLL Number:
Test gear available: Multimeter, scope, counter, sig gen
Symptoms: No response from band, channel, indicator buttons.

What is working: TX ok when keying mic. Frequency dial OK.

What has been tried: Checked operation of buttons and row and column signal lines. Three have 5V and two have 0V. No wires are loose or disconnected.

Did it suddenly happen ?: Yes, following further repair work done to the radio. Replaced smashed RF power control, realigned some twiddled settings, replaced backlight and removed some strange mod. Problem occurred after working on front panel. Keypad was working. Operator/repair skill resonable.

Anything else that may be of help?: Could be problem associated with 11m mods and incompatibility with certain cpus. A few mods were tried before success. Upon first inspection 34 and 35 were soldered together. I then connected them to the last pin on the resistor pack. This only worked intermittently, giving me reason to suspect something wrong. The problem occurred (not immediately) afterwards. Mod was completed with 4.7k resistor from +5v to 34 and 35.

Re: President Lincoln control buttons not working

Posted: Saturday 5th Mar 2011, 13:19
by zodiac
All you need do is put a link as shown in the diagram to open it up.

Re: President Lincoln control buttons not working

Posted: Saturday 5th Mar 2011, 21:54
by absorbentgnome
Ok thanks Zodiac :)
There are solder marks on those components, so it probably has been done before.
Have you seen inoperable front panel buttons before?
Dan.

Re: President Lincoln control buttons not working

Posted: Sunday 6th Mar 2011, 3:33
by zodiac
Inoperable, now there's a word I wouldn't have used.
I can't say that I have, unless the processor been knackered.
Scott is the expert on Lincoln’s but it doesn't help not being able to find a good schematic that isn't full of blobs and unreadable, plus there's not a lot of screen printing on the board for identifying components.
There is a schematic on CBTrick for the CPU board drawn by Rick, now if he'd drawn the rest of the radio it would have been a great help but it takes up a lot of time to do and get it right.
I've got a 2830 with the beep button that when it's pressed in the beep doesn't work nor does the TX on any mode but with it out there's no problem TX is fine.

Re: President Lincoln control buttons not working

Posted: Tuesday 8th Mar 2011, 2:15
by absorbentgnome
Thanks for your help zodiac, have tested between known good transceiver and this one and have come to the conclusion that the processor is damaged.
Hopefully a replacement will be on its way soon.
Dan.

Re: President Lincoln control buttons not working

Posted: Wednesday 9th Mar 2011, 19:36
by The Defpom
I should drop in here more often by the looks !

I wish I wasn't so busy with other things, anyway.

One thing to try, as weird as it will sound, is swap out the LCD PCB, I have seen instances where a faulty LCD PCB has caused the MPU to appear to be faulty, it is a long shot, but an easy thing to rule out if you have a second one to try out, if the PCB is faulty sometimes just resoldering every single through hole on it can fix it :-)

I would also suggest checking/replacing RR303 (the resistor array which is used on the press button inputs).

I also suggest resoldering every pin in the MPU, as it is through hole, with a double sided PCB I have seen faulty solder joints on the top side pins connections cause problems.

Re: President Lincoln control buttons not working

Posted: Saturday 12th Mar 2011, 4:27
by absorbentgnome
Hi Scott
Thanks for your reply. The resistor array checks OK. When the CPU comes I'll post back here if it fixed it or not. Soldering on the CPU looks absolutely perfect, no bad joints, board is in immaculate condition with no corrosion. On your advice, I will check the thru holes associated with the CPU pins when changing the CPU over :)

Re: President Lincoln control buttons not working

Posted: Friday 18th Mar 2011, 22:13
by absorbentgnome
Changed CPU over, all working now :)

Method used for desoldering:

IC removal done with hot air station at about 330oC for each side of the chip, levering it out slowly from either side. A lot of heat, time and patience is needed to get the board up to temperature to weaken or melt the solder for a single row of 32 pins and lever the side of the chip out. Once removed, tidy up the through holes with solder wick and an iron, from both sides of the board if necessary. Blocked holes can be opened with a dental pick heated with the iron. Check all through hole connections are intact, note to repair any that came out with the chip (1 in my case) after the new one is put in.

Re: President Lincoln control buttons not working

Posted: Monday 21st Mar 2011, 22:23
by The Defpom
Glad to hear you got it sorted out.

An easy way of getting the existing MPU IC out is to actually cut all the pins off the IC, and then desolder and remove them one by one, I found that to be one of the simplest ways of getting a faulty one out, and also helps avoid damaging the PCB traces from excessive heating etc.

It sounds like your method worked OK for you though.

Re: President Lincoln control buttons not working

Posted: Wednesday 9th Nov 2011, 15:32
by KC7NOA
Where did you get a replacement CPU?