RM KLV350 short circuits?

For discussions dealing with CB Radio Amplifiers.
Post Reply
Breaklight
Dead Key
Dead Key
Posts: 10
Joined: Friday 22nd Aug 2008, 4:58
Location: Rotterdam

RM KLV350 short circuits?

Post by Breaklight » Sunday 16th Aug 2009, 3:05

Hi all!

Today I received a RM KLV350 with a possible short circuit problem from a very dissapointed owner and good friend. I've tried some plausible solutions but none worked. The thing is that when the amp is switched on and on stand-by, transmitting/receiving is no problem and the valves light up normally. When the amp is switched to power and a TX is applied the fuse blows with a bright flash. The first time this occurred while transmitting.

In my opinion some part must have given way which causes leakage to ground :?:

I consulted rmitaly.com to obtain the partslist, layout and schematic info and at first i thought D7 had blown which could cause a major leakage to ground so the fuse blows up.

Could anybody have an idea where to look for?

Any help will be enormously appreciated!!

Cheers!

Breaklight

19WAC495
RG2950DX, Lincoln, Imax2000

Breaklight
Dead Key
Dead Key
Posts: 10
Joined: Friday 22nd Aug 2008, 4:58
Location: Rotterdam

Re: RM KLV350 short circuits?

Post by Breaklight » Sunday 16th Aug 2009, 10:44

... meanwhile I checked all the capacitors and diodes... all fine. I checked the relay switch as well and it works properly. Only thing left seem to be the valves..? What I found out is that when the amp is hooked up between the transceiver and the antenna it gives a bad SWR whereas my own amp doesn't do anything to the SWR... :roll:

So what's next?
RG2950DX, Lincoln, Imax2000

zodiac
Technical Helper
Technical Helper
Posts: 319
Joined: Sunday 7th Nov 2004, 13:58
Location: UK

Re: RM KLV350 short circuits?

Post by zodiac » Saturday 22nd Aug 2009, 10:27

Check you don't have a valve that is shorted from the top cap to the pins at the bottom, there should be no connection between then.
You will have to remove the valves to do the test.
Dave.
How far is it.
Twice it's length from halfway.

Breaklight
Dead Key
Dead Key
Posts: 10
Joined: Friday 22nd Aug 2008, 4:58
Location: Rotterdam

Re: RM KLV350 short circuits?

Post by Breaklight » Saturday 22nd Aug 2009, 20:40

Hi Dave,

Sounds plausibel to me. At this point an order has been placed to obtain two new valves as nothing else seems to give any troubles. I didn't get the chance to test the amp without the valves fitted so I'll do this a soon as possible... it probably (hopefully) figures :wink:

Thanks for the help!

John.
RG2950DX, Lincoln, Imax2000

zodiac
Technical Helper
Technical Helper
Posts: 319
Joined: Sunday 7th Nov 2004, 13:58
Location: UK

Re: RM KLV350 short circuits?

Post by zodiac » Thursday 19th Aug 2010, 13:55

John,
Did you find the problem with the Amp ?.
I just had one in today with the same fault and it had one shorted valve.
Dave.
How far is it.
Twice it's length from halfway.

dlambeth
Newbie
Newbie
Posts: 2
Joined: Saturday 5th May 2012, 3:10
First Name: Darwin
Location: San Antonio Texas
Contact:

Re: RM KLV350 short circuits?

Post by dlambeth » Saturday 5th May 2012, 3:16

Having same problem. Has anyone figured out what is causing this? I seem to think it's shorted Tube.

Thanks,

PatrickSpencer
Newbie
Newbie
Posts: 1
Joined: Monday 9th Jul 2012, 16:19
First Name: Patrick
Location: USA
Contact:

Re: RM KLV350 short circuits?

Post by PatrickSpencer » Sunday 29th Jul 2012, 23:38

Information sharing and communication is very important because without proper information, advancement and
improvement is not possible.Thanks for sharing information.

Post Reply

Return to “CB Radio Amplifiers”