RM KL200 distortion

For discussions dealing with CB Radio Amplifiers.
Post Reply
buzzby
Dead Key
Dead Key
Posts: 25
Joined: Sunday 22nd Nov 2009, 13:37
First Name: philip
Location: northern ireland

RM KL200 distortion

Post by buzzby » Friday 4th Dec 2009, 8:55

I GOT THIS AMP SECONDHAND but it seems to distort the modulation when i am using it on ssb i am getting bad reports with it switched on, when i first got this amp i was using it on fm ( i forgot to switch amp off after dxing on ssb) and the resistor (R9) melted the solder and one leg off the resistor had come off the pcb ( an easy fix) but snice i have been told that the modulation has been distorted would this resistor be fryed or have i done a bit more damage to the amp any help would be great many thanks philip :-k
Last edited by buzzby on Monday 11th Jan 2010, 5:29, edited 1 time in total.

zodiac
Technical Helper
Technical Helper
Posts: 319
Joined: Sunday 7th Nov 2004, 13:58
Location: UK

Re: RM KL200

Post by zodiac » Wednesday 16th Dec 2009, 3:22

Philip,
There is no adjustment to be made to the Amp to put it on frequency, that's done in the radio.
What gose into the Amp comes out on the same frequency.
How far is it.
Twice it's length from halfway.

User avatar
Animal
Light User
Light User
Posts: 125
Joined: Thursday 18th Jan 2007, 8:13
Location: Location : Location

Re: RM KL200 distortion

Post by Animal » Wednesday 24th Feb 2010, 7:49

Phillip

If you TX when the switch on the amp is in the FM position, it doesn't damage the unit.

The FM/SSB switch just activates the delay on SSB (or de-activates it in AM/FM mode)

Are you running the amp mobile or homebase?

If homebase, what PSU are you using & how many amps can it deliver?

What is your SWR reading?
You're 5 & 9 - what's your QRZ again???

buzzby
Dead Key
Dead Key
Posts: 25
Joined: Sunday 22nd Nov 2009, 13:37
First Name: philip
Location: northern ireland

Re: RM KL200 distortion

Post by buzzby » Thursday 25th Feb 2010, 8:26

How are you animal, at the minute i am using a car battery to power my amp and my swr is at a 1.2 without it and 1.4 with it , but i have been getting bad reports with it, not sure whats going on with it i had to fix a risister in it one day when the legs of it came free of the pcb but snice it has not been the same, i done a full check of the resister and its 100% ,maybe there is something else gone wrong any help would be brill ........ i also have another post in the cb radio troubleshooter, would you also have any ideas about my ranger, many thanks philip. 73's :?

User avatar
Animal
Light User
Light User
Posts: 125
Joined: Thursday 18th Jan 2007, 8:13
Location: Location : Location

Re: RM KL200 distortion

Post by Animal » Saturday 27th Feb 2010, 5:04

Philip

Do you have a trickle charger connected to the battery all the time? If not, I'd consider it.

I found that when I was mobile using a KL-500 I needed to have the engine running (with alternator charging the battery) otherwise I'd get 'distorted audio' reports - those things could draw well over 40A at full tilt! :shock:
You're 5 & 9 - what's your QRZ again???

buzzby
Dead Key
Dead Key
Posts: 25
Joined: Sunday 22nd Nov 2009, 13:37
First Name: philip
Location: northern ireland

Re: RM KL200 distortion

Post by buzzby » Saturday 27th Feb 2010, 9:29

yes i do have a small 12v battery charger on this battery and this battery is for a diesel car so the ampage is more than enough for this burner,,i am thinkin maybe i am putting to much power into this burner, but my set only puts out 6 watts on ssb which should be low enough to drive this burner, it has me at a loss!,, not sure what else to try maybe there is something else gone wrong with this amp.......but it works, but it must not suit my set i am also using a skipmaster 42000 desk mike maybe its overdriving the amp any more input would be brill, thanks for helping me with this many thanks philip......... :)

zodiac
Technical Helper
Technical Helper
Posts: 319
Joined: Sunday 7th Nov 2004, 13:58
Location: UK

Re: RM KL200 distortion

Post by zodiac » Tuesday 29th Jun 2010, 9:18

Philip,
The reply I gave above has nothing to do with your question on the amp, don't know why I wrote that. :oops:
You say your using a desk mike, when you key up without talking does the needle on the meter move to indicate power out ?. The reason I ask is that if the mike is too high it will pick up background noises that you may not be able to hear but the mike can and it makes a right racket on air and this may be the cause of the distortion people are reporting to you.
The resistor you re-soldered back in got too hot for the reason you said, too long an over on FM, once re- soldered back in it should be OK again.
Using a battery charger to top up the battery while in use will help but only if the battery is in good condition, just because it's off a diesel car doesn't mean it's in good condition, having said that if there's no warbling being reported to you then you can take it the battery and the charger are both working fine unless side band RF is getting in to the charger, as they are a very rough circuit with no smoothing capacitors or filters built in .
Try using the amp without the charger on just to see if it stops the distortion.

Dave.
How far is it.
Twice it's length from halfway.

Post Reply

Return to “CB Radio Amplifiers”