PALOMAR ELITE 450HD PART IDENTIFICATION

For discussions dealing with CB Radio Amplifiers.
Post Reply
User avatar
speedracer6g
Light User
Light User
Posts: 165
Joined: Saturday 23rd Feb 2008, 13:35
First Name: Michael
Location: East Freedom, PA
Contact:

PALOMAR ELITE 450HD PART IDENTIFICATION

Post by speedracer6g » Saturday 12th Jun 2010, 1:15

I have a palomar elite 450hd amp that had a resistor burnt to badly to identify. I cant find any schematic on this thing. Does anyone know what the value of R19 in this amp.

thanks,

Mike

zodiac
Technical Helper
Technical Helper
Posts: 319
Joined: Sunday 7th Nov 2004, 13:58
Location: UK

Re: PALOMAR ELITE 450HD PART IDENTIFICATION

Post by zodiac » Monday 14th Jun 2010, 14:15

Mike,
Can you give a little more info as to the location of the resistor in the amp, as someone may be able to help you.
How far is it.
Twice it's length from halfway.

User avatar
speedracer6g
Light User
Light User
Posts: 165
Joined: Saturday 23rd Feb 2008, 13:35
First Name: Michael
Location: East Freedom, PA
Contact:

Re: PALOMAR ELITE 450HD PART IDENTIFICATION

Post by speedracer6g » Tuesday 15th Jun 2010, 2:10

AMP PIC.JPG
(344.84 KiB) Downloaded 339 times
I replaced the part with a resistor already as seen in the pic i attached. R19 is beside the keying relay. when i key up but on med and high power it stays keyed after you unkey the transmitter. I dont think this is the main cause of this but i would like to get this part back to OEM. The amp seems to be self oscillating on high and med power on an antenna. It dosnt do this on a dummy load. I have tried it on my bench antenna and the customers. Any thoughts or suggestions??

thank you,

Mike

zodiac
Technical Helper
Technical Helper
Posts: 319
Joined: Sunday 7th Nov 2004, 13:58
Location: UK

Re: PALOMAR ELITE 450HD PART IDENTIFICATION

Post by zodiac » Thursday 24th Jun 2010, 11:24

I've had the same problem many times, sometimes I fix them and sometimes I don't.
Try changing the relay switching transistor and the two IN4148 rectifying diodes to the base of the same transistor, it works for me now and again but not always.
Dave.
How far is it.
Twice it's length from halfway.

User avatar
speedracer6g
Light User
Light User
Posts: 165
Joined: Saturday 23rd Feb 2008, 13:35
First Name: Michael
Location: East Freedom, PA
Contact:

Re: PALOMAR ELITE 450HD PART IDENTIFICATION

Post by speedracer6g » Friday 25th Jun 2010, 4:40

Thanks, I will give that a try and see what happens.

MIke

Post Reply

Return to “CB Radio Amplifiers”