Icom W2A works great on Ext power, Won't power up on battery

A section for Marine radios, VHF and UHF radios, for all types of discussions dealing with these types.
Post Reply
RedEye
Light User
Light User
Posts: 140
Joined: Wednesday 29th Nov 2006, 15:38
Location: Clermont, Florida

Icom W2A works great on Ext power, Won't power up on battery

Post by RedEye » Wednesday 23rd Apr 2008, 2:51

I have 2 Icom W2A dual band VHF/UHF handhelds that were given to me. Both work very well, and both will charge batteries through the Ext power plug on the top. However when the ext power is removed the radios power off, 3 different batteries (one new) all hold and maitain charge well.

I found out the owner used them both in his chevy S-10 on cigarette lighter power plug, and it turns out his alternator is putting out 18 volts!

Is there a diode that allows the ext power to flow to the battery to charge, but not let the bbattery power the radio? Any help would be greatly appreciated!!!!!

73's

User avatar
Rick
Technical Helper
Technical Helper
Posts: 1041
Joined: Sunday 4th Jun 2006, 12:52
Location: UK

Re: Icom W2A Will not power up on batteries.

Post by Rick » Monday 28th Apr 2008, 5:26

The fault is most like to be on the PRT Unit, which is at the bottom for the radio just above the battery connectors, as this PCB is SMT board when I get one in with this fault I just replace the PRT Unit.

If you want to do some digging around on the PRT check Q1, D1, and D2 if you have a later W2 check R4 as maybe open.
Rick.

RedEye
Light User
Light User
Posts: 140
Joined: Wednesday 29th Nov 2006, 15:38
Location: Clermont, Florida

Post by RedEye » Friday 9th May 2008, 13:04

Thanks a ton Rick, I'll check tonite, Found a local Icom dealer, I'll look into getting a new PRT.

Post Reply

Return to “Marine, VHF and UHF Radios”