Search found 258 matches

by timrim
Friday 30th May 2008, 8:57
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

Pin 2 of PLL is 2.71 Mhz .... Pin 6 of IC-10 is where I get 3.4 Pin 9 of IC-10 also has correct frequency Just Replaced IC10 and still not operating. I use the following schematic: http://www.cbtricks.com/radios/galaxy/dx88hl/graphics/sch_dx88hl.pdf Pin 6 of IC-10 is used. Hope this helps. At least ...
by timrim
Friday 30th May 2008, 8:36
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

If earlier it was correct, perhaps it was with the PLL controlling the VCO, In these tests, I was using a seperate variable power supply to control the vco. I think I will swap it out and see what happens. I just swapped out IC-10. No change, still not working. Pin 6 is 3.491 Mhz And that was tested...
by timrim
Friday 30th May 2008, 8:20
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

The Defpom: Yes, Pin 3 has 10.240 Signal GRTS: Using your troubleshooting method, I have the following results: IC10 Pin 2 13.560 Mhz Looks Ok IC10 Pin 6 3.4 Mhz and drifting a bit Way off IC10 Pin 7 16.270 Mhz Looks Ok TR25 and 26 Have the 16.270 signal So, Because Pin 6 of IC-10 is wrong, that mea...
by timrim
Thursday 29th May 2008, 12:54
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

Initial Check On R-116 PLL side was 0 and other side is was 8V (May not have made proper contact with probe?) Removed, and reinstalled R-116...8V on PLL side 3.4 Volts on VCO Side Radio worked for a few minutes and quit again. Both sides of R-116 Are 8 volts with no noticeable difference. I'll exami...
by timrim
Thursday 29th May 2008, 12:37
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

OK, try adjusting the VCO so that the freq at TP3 is 16.270MHz, and then re-check PLL pin 2, you should get 2.71MHz Yes, that is correct! Voltages at R-118 is 8 and 7.7 Binary Codes to PLL are correct. Initial Check On R-116 PLL side is actually 0 and other side is 8V Removed, and reinstalled R-116...
by timrim
Thursday 29th May 2008, 10:47
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

Pin2 of PLL 3.165 Mhz

16.725 at TP 3 in front of L43
by timrim
Thursday 29th May 2008, 10:32
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

Thanks for fast response, I will try to locate the test point and let you know what frequency I get.


EDIT: VCO Is drifting at ~19Mhz
Looking for Down converted signal now

Tim
by timrim
Thursday 29th May 2008, 10:16
Forum: CB Radio Repair and Troubleshooting
Topic: Galaxy DX 88 VCO Problem
Replies: 39
Views: 30054

Galaxy DX 88 VCO Problem

VCO voltage at TP2 is 8V. I have replaced the PLL, what else should I check to trouble shoot problem?

NOTE: VCO adjustment never allows voltage to go below 8 volts.

Thanks in advance,
Tim

Go to advanced search